Users receiving 'something went wrong' or 'Hash MHHY91' Error messages when using Apps

Incident Report for Jira

Resolved

Our team has continued to monitor the errors relating to accessing Apps and we are now satisfied that this issue is fully resolved.
Posted Sep 08, 2025 - 05:49 UTC

Monitoring

We have implemented a mitigation for the issue affecting access to 3rd party Apps. At this time, services are operating as expected and we are closely monitoring the situation to ensure continued stability. We will provide further updates if there are any changes.
Posted Sep 04, 2025 - 15:11 UTC

Identified

We have identified the issue that might happen after multiple page refreshes. A temporary workaround for users is to avoid performing a full page refresh; instead, try switching between different tabs within the interface to reload third-party applications. Our team is actively working on fixing this issue and will provide updates as soon as more information becomes available.
Posted Sep 04, 2025 - 07:45 UTC

Update

Our team is continuing to investigate this issue. We will provide further updates when available.
Posted Sep 04, 2025 - 05:02 UTC

Investigating

We are aware of some users currently receiving error messages such as 'something went wrong' or 'Hash MHHY91' when attempting to access 3rd party Apps. Our team is investigating with urgency and we will provide an update as soon as possible.
Posted Sep 04, 2025 - 00:53 UTC
This incident affected: Viewing content, Create and edit, Authentication and User Management, Search, Notifications, Administration, Marketplace, Mobile, Purchasing & Licensing, Signup, and Automation for Jira.